Support Forum Support Forum GDPR Cookie Compliance Shortcode [settings] and Settings button do not work

Topic Resolution: Resolved
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Premium
    AvatarJohannes Larsson
    February 06, 2020 @ 6:04 pm

    Hi, we just purchased your GDPR plugin and trying to set it up on our staging server.

    Settings: http://prntscr.com/qykmmx

    What is displayed: http://prntscr.com/qykn1c

    Clicking the button does nothing. I have enabled Strictly, 3rd-Party and Additional Cookies. Also added some dummy Declarations.

    What else is needed to show the settings page?

    Thank you for your time.

    Moove AgencyMoove Agency
    February 07, 2020 @ 9:05 am

    Hi Johannes,

    Thanks for using our plugins.

    1. The reason why the setting button is displayed in other position than defined in your settings:
    Our moves the settings button if the full screen / cookiewall is enabled to the footer section of the full screen banner. If you prefer to show the setting as a link in your content, you can use a link for settings (using the WYSIWYG editor link feature) using the following ID as a string: #gdpr_cookie_modal
    So you banner text will be

    We are using cookies to give you the best experience on our website.
    You can find out more about which cookies we are using or switch them off in settings.
    [setting]Settings[/setting]

    Where the settings will be a link to #gdpr_cookie_modal

    2. The setting button in your site it doesn’t work because you pasted a wrong CDN URL to GDPR Cookie Compliance -> Branding (tab) -> CDN Base URL (field)
    Please ensure, if you have no CDN activated for your site keep this field empty. The Lity.js is missing: https://cdn.fi***er.com/wp-content/plugins/gdpr-cookie-compliance/dist/scripts/lity.js and you have a lot of console errors. These console errors related to our plugin should be fixed in order to fix the settings and other functionalities on your site.
    Screenshot: https://prnt.sc/qyu9bx

    Hope this helps.

    Premium
    AvatarJohannes Larsson
    February 09, 2020 @ 1:33 pm

    You were right, the link in the modal box should point to #gdpr_cookie_modal. Also, the button issue and all the console errors were gone when I removed the cdn reference. This is a staging server as you can see so when I will deploy it to production I should add the cdn back. Thank you for your help.

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.